AutoCAD Memory Leak aka Undo Stack aka Memory Chunk Issue

General support questions regarding the use of DraftLogic Electrical that don't fit into any of the more specific forums.

AutoCAD Memory Leak aka Undo Stack aka Memory Chunk Issue

Postby forumadmin » Sun Sep 16, 2012 1:17 pm

Have you ever glanced at the Processes tab on the Windows Task Manager to see how much memory 'acad.exe' is taking up? On my computer, acad.exe is taking up about 150MB when it is first launched. After a heavy DraftLogic Electrical session running Automated Placement on a 360 room project, acad.exe takes up 2.1GB!

Performance Spirals Down As Memory Use Increases

Needless to say, AutoCAD's processing speed plummets when its memory footprint causes it to have to use the page file (i.e. swapping working memory between RAM and the hard drive). DraftLogic Electrical performs tens of thousands of operations in the time a CAD operator working manually would only perform a mere fraction of that many operations. DraftLogic Electrical thus pushes AutoCAD into paging file use much sooner than a manual drafter does.

Automated processes that do a lot of work in DraftLogic Electrical, like a complete reports batch or Automated Placement on a large project, will eat memory quite quickly.

Batch Size Management

You can optimize the time that Automated Processes take by breaking major work into pieces for processing. For example, if you have a four floor building comprising about 400 rooms that you wish to run Automated Placement on, run Automated Placement on each floor separately by using the Select option and do a crossing selection on each floor rather than using the All default option for Automated Placement to run the entire project all at once.

Inbetween each piece of the batch, check your AutoCAD memory usage to see if a Save, Close, Reopen is called for.

The DraftLogic Electrical processes that benefit most from this treatment are Automated Room Creation and Automated Placement.

Why, Why, Why?

The technical reasons behind this 'eating of memory' are reported with various reasons on the Internet...but you shouldn't believe everything you read on the Internet, right? The important thing is to have a solution...

Easy Solution

Regardless of the reason(s) behind AutoCAD eating memory, the solution is quite simple: keep an eye on your acad.exe memory usage, and when it exceeds a comfortable portion of your physical memory just save your file & close/reopen AutoCAD. Closing AutoCAD releases all the memory that it was holding & your memory usage will be down to a manageable level on the reopen of AutoCAD. On my 4GB Windows 7 x64 system, I usually try and do this whenever the acad.exe process exceeds 1GB of memory.
forumadmin
Site Admin
 
Posts: 87
Joined: Fri Sep 11, 2009 5:46 am

Return to General Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron